Update auf Snow Leopard

Snow Leopard

Snow Leopard

Nun ist es endlich soweit. Mac OS 10.6 ist erschienen. Da das Update aber bisher nicht in Jakarta erhältlich ist, habe ich die Gelegenheit genutzt es auf meinem „Ausflug nach Singapore“ zu erwerben. Der Preis 44,86 Singapore Dollars (ca. 21 Euro).

Ich habe mich dann auch gleich daran gemacht, das Update auf meinem MacBookPro zu installieren. Im grossen und ganzen ging das Reibungslos. DVD rein, auf Mac OS X Installation klicken. Ca. 45 Minuten warten. Einmal reboot und das System kommt, fast, ohne Probleme wieder hoch.

Die eine oder andere Software beschwert sich, dass sie Rosetta gerne installiert hätte, um zu funktionieren. Da habe ich erst mal nichts unternommen. Es handelte sich ohnehin um Software, die ich nicht mehr benötigte. Ausserdem Funktioniert auch die eine oder andere Erweiterung (vorläufig) nicht mehr.

Das sind z.B. Erweiterungen des Safari wie „adblock“, „Speed Download“ oder „1Password“. Für Speed Download gibt es aber bereits ein Update. Für 1Password eine Beta der Version 3.0 die man verwenden kann und die bisher auch ohne Probleme bei mir läuft.  Für Adblock wird es hoffentlich bald etwas geben.

Auch für Flip4Mac muss man auf ein Update warten. Allerdings scheint Quicktime X bisher alles ohne zu klagen abzuspielen. Was etwas mehr schmerzt, ist „iStat Menus“. Aber auch hier ist das Update angekündigt. Growl funktioniert bei mir, entgegen anders lautenden Gerüchten in einigen Foren, klaglos.

Nun aber zu den Problemen:

Das erste, was ich feststellte war, das ich plötzlich keine Software mehr installieren konnte. Immer wenn im Installer der Moment kam, auf „Installieren“ zu klicken, passierte anschliessend nichts. Die Taste wurde kurz grau, dann wieder normal. Man konnte klicken so viel man wollte, es passierte nichts. Schon ärgerlich, wenn sich Updates nicht installieren lassen. Ich habe versucht, den Grund in den Systemeinstellungen zu finden. Hier gab es die nächste Überraschung: wenn eine Einstellungspanel gesperrt war, liess dieses nicht entsperren. Bei Klicken auf das Schloss erschien kurz „Identifizierung“ und dann war der Spass auch schon vorbei. Es wurde weder identifiziert noch wurde die Sperre aufgehoben. Da musste echt was faul sein. In den logfiles fand ich heraus, dass der SecurityAgent abnormal beendet wurde. Aber warum? Ich tippte darauf, dass wohl irgendwo eine preferences Datei faul war. In diversen Foren fand ich diese Vermutung auch bestätigt. Allerdings hatte noch keiner herausgefunden, welche es tatsächlich war. Ich habe es also getestet: Alle plist Dateien aus ~/Library/Preferences verschoben. Abmelden. Anmelden. Alles funzt. Na grossartig. Aber welche der vielen Dateien ist es denn nun? Der Forumsempfehlung, die Dateien eine nach der anderen wieder zurück zu kopieren und zu testen, erschien mir viel zu Mühselig. Da muss es auch was anderes geben. In dem Moment viel mir ein, dass es in Max OS X seit Leopard dtrace gibt. Also fix ein script geschrieben, das mal schaut welche Dateien der SecurityAgent so öffnet. Und da fand ich den Übeltäter:  ~/Library/Preferences/ByHost/com.apple.HIToolbox……plist. Diese Datei gelöscht. Abmelden. Anmelden. Siehe da: Man kann sich wieder authentifizieren. Allerdings war jetzt meine Tastaturbelegung etwas anders. Die war, entsprechend meine System, jetzt Deutsch. Das passte aber nicht zu meiner Tastatur. Die ist nämlich amerikanisch. Ausserdem hatte ich noch ein spezielles Tastaturlayout installiert. Damit kann man auf der amerikanischen Tastatur deutsche Umlaute schreiben. Ich habe also alles wieder darauf umgestellt. Blöd nur: jetzt klappte die Authentifizierung wieder nicht mehr. Wieder zurück auf einfach amerikanisch: Geht wieder. Hm. Gibts halt erst mal keine Umlaute.

Zweites Problem war, dass ich das Standardprogramm zum öffnen von Dateien nicht für alle Dateien eines Typs ändern konnte. Im Dialog „Information“ zu einer Datei konnte man zwar unter „Öffnen mit …“ ein Programm auswählen, aber der Button „Alle ändern“ war grau. Aber auch dafür gibt es eine Lösung: die Datei com.apple.LaunchServices.plist löschen. Danach sind alle diese Einstellungen auf Standard und mann kann sie anpassen.

Weitere Probleme habe ich bisher nicht feststellen können. Alles läuft jetzt bestens.

Kommentar schreiben

2 Kommentare.

  1. Ein etwas teurerer Ausflug | Reiseberichte - pingback on 31. August 2009 um 14:23
  2. Das Problem mit den Keyboard Plugin und der fehlenden Authentifizierung lässt sich relativ leicht lösen, und zwar installiert man das Plugin statt in seinem Benutzerverzeichnis/Library/Keyboard Layouts, auf der höchsten Verzeichnisebene (root-Verzeichnis) direkt in /Library/Keyboard Layouts
    Danach kann man das Tastaturlayout – wie gewohnt – über die Systemeinstellungen aktivieren, und kann danach die Passwörter eintippen
    Schönen Gruß aus Aachen,
    Damian

Kommentar schreiben


Hinweis - Du kannst dies benutzenHTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Trackbacks und Pingbacks: